HTTP 503 / 508
503 entsteht bei erschöpftem Speicher oder Timeout, 508 bei zu vielen PHP‑Threads; prüfe den Ressourcenverbrauch, optimiere den Cache oder upgrade das Paket.
HTTP 503
HTTP 503‑Fehler kann auftreten, wenn ein Webhosting die gesamte verfügbare Speicherressource des gewählten Produkts verbraucht hat, oder wenn ein Skript abläuft.
HTTP 508
Dieser Fehler tritt auf, wenn das einzelne Webhosting zu viele gleichzeitige PHP‑Threads laufen hat.
Ein Webhosting kann diesen Fehler erleben, wenn es unter Angriff steht oder das Webhosting nicht gut genug optimiert ist, um viele gleichzeitige Besuche zu bewältigen, z. B. von Crawlern.
Was du tun kannst
Du kannst den aktuellen Ressourcenverbrauch deines Webhostings im Menüpunkt „Website“ in unserem Kontrollpanel verfolgen. Dort, unter „Ressourcenverbrauch“, ist außerdem näher beschrieben, was du tun kannst, um das Problem zu beheben.
Untersuche die Protokolle unter „Webserver‑Logs“ in unserem Kontrollpanel, um zu sehen, ob deine Seite angegriffen wird oder ein Crawler das Problem verursacht.
Optimieren (mit Caching)
Das Problem kann auftreten, wenn schlechte Plugins installiert sind oder schwere SQL‑Abfragen laufen, auf die die PHP‑Threads warten.
Stelle stets sicher, dass du Cache‑Module und andere Funktionen aktivierst und installierst, die den Ressourcenverbrauch deines Webhostings reduzieren können.
Wenn du WordPress nutzt, kannst du versuchen, WordPress über unser WordPress‑Werkzeug zu optimieren, das du in unserem Kontrollpanel findest.
Zusätzliche Ressourcen erwerben
Oft liegt die Ursache des Fehlers lediglich darin, dass deine Seite dabei ist, aus dem aktuellen Hosting‑Paket bei uns „herauszuwachsen“, und du kannst daher zu einem größeren Paket mit mehr Ressourcen wechseln, um das Problem zu beheben.
Du kannst dein Produkt zu einem größeren Paket mit mehr PHP‑Threads upgraden und damit das Ressourcen‑Limit erhöhen. Upgrade dein Produkt über unser Kontrollpanel.
PHP‑Threads neu starten
Eine vorübergehende Lösung des Problems kann darin bestehen, alle PHP‑Prozesse/Threads im Webhosting neu zu starten. Das geschieht im Menüpunkt „Website“ in unserem Kontrollpanel.
Artikel aus der Support-Kategorie: PHP