Simply.com is available in english

HTTP 503 / 508

503 treedt op bij geheugenuitputting of timeout, 508 bij te veel PHP‑threads; controleer resourcegebruik, optimaliseer cache of upgrade het pakket.

HTTP 503

HTTP 503-fout kan optreden wanneer een webhosting al het geheugen heeft gebruikt dat beschikbaar is in het gekozen product, of wanneer een script time‑out bereikt.

HTTP 508

Deze fout treedt op wanneer het individuele webhostingplan te veel gelijktijdige PHP‑threads heeft draaien.

Een webhosting kan deze fout ervaren als het onder aanval staat of als het webhostingplan niet goed genoeg is geoptimaliseerd om veel gelijktijdige bezoeken te verwerken, bijvoorbeeld van crawlers.

Wat kun je doen

Je kunt het actuele resourcegebruik van je webhosting volgen onder het menu‑item "Website" in ons Controlepaneel. Hier staat onder "Resourcegebruik" ook nader beschreven wat je kunt doen om het probleem te verhelpen.

Bekijk de logs onder "Webserver logs" in ons Controlepaneel om te zien of je site onder aanval is of dat een crawler de oorzaak is van het probleem.

Optimaliseer (met caching)

Het probleem kan ontstaan als er slechte plugins zijn geïnstalleerd, of als er zware SQL‑calls worden uitgevoerd waar de PHP‑threads op wachten.

Zorg er altijd voor dat je cache‑modules en andere functies activeert en installeert die het resourcegebruik van je webhosting kunnen verminderen.

Als je WordPress gebruikt, kun je proberen WordPress te optimaliseren via ons WordPress‑gereedschap dat je vindt in ons Controlepaneel.

Koop extra resources

Vaak is de oorzaak van de foutcode simpelweg dat je site de huidige hosting‑paket bij ons begint te overschrijden, en kun je daarom upgraden naar een groter pakket met meer resources om het probleem te verhelpen.

Je kunt je product upgraden naar een groter pakket, met meer PHP‑threads, en zo het resource‑limiet verhogen. Upgrade je product via ons Controlepaneel.

Herstart PHP‑threads

Een tijdelijke oplossing voor het probleem kan zijn om alle PHP‑processen/threads op de webhosting te herstarten. Dit doe je onder het menu‑item "Website" in ons Controlepaneel.

Artikel uit de ondersteuningscategorie: PHP