HTTP 503 / 508
503 ocurre por falta de memoria o timeout, 508 por demasiados hilos PHP; verifica el consumo de recursos, optimiza la caché o actualiza el plan.
HTTP 503
El error HTTP 503 puede ocurrir cuando un alojamiento web ha utilizado toda la memoria disponible en el plan seleccionado, o cuando un script se agota.
HTTP 508
Este error ocurre cuando el alojamiento web individual tiene demasiados hilos PHP concurrentes en ejecución.
Un alojamiento web puede experimentar este error si está bajo ataque o si el alojamiento no está lo suficientemente optimizado para manejar muchas visitas simultáneas, por ejemplo, de crawlers.
Qué puedes hacer
Puedes seguir el consumo de recursos actual de tu alojamiento web bajo el menú "Website" en nuestro Panel de Control. Allí, bajo "Consumo de recursos", se describe con más detalle qué puedes hacer para mitigar el problema.
Revisa los registros bajo "Webserver logs" en nuestro Panel de Control para ver si tu sitio está bajo ataque o si un crawler es el culpable del problema.
Optimizar (con caché)
El problema puede surgir si hay plugins deficientes instalados, o si hay llamadas SQL pesadas en ejecución, que hacen que los hilos PHP esperen.
Asegúrate siempre de activar e instalar módulos de caché y otras funciones que puedan reducir el consumo de recursos de tu alojamiento web.
Si utilizas WordPress, puedes intentar optimizar WordPress mediante nuestra herramienta WordPress que encontrarás en nuestro Panel de Control.
Comprar más recursos
A menudo la causa del código de error es simplemente que tu sitio está "creciendo" fuera del plan de hosting actual con nosotros, y puedes actualizar a un plan más grande con más recursos para mitigar el problema.
Puedes actualizar tu producto a un plan más grande, con más hilos PHP, y así elevar el techo de recursos. Actualiza tu producto a través de nuestro Panel de Control.
Reiniciar hilos PHP
Una solución temporal al problema puede ser reiniciar todos los procesos/hilos PHP en el alojamiento web. Esto se hace bajo el menú "Website" en nuestro Panel de Control.
Artículo de la categoría de soporte: PHP